PAT 甲级 1027 Colors in Mars (20 分) 进制转换问题 我的代码+别人的代码
1027 Colors in Mars (20 分)
People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red
, the middle 2 digits for Green
, and the last 2 digits for Blue
. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.
Input Specification:
Each input file contains one test case which occupies a line containing the three decimal color values.
Output Specification:
For each test case you should output the Mars RGB value in the following format: first output #
, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0
to its left.
Sample Input:
15 43 71
Sample Output:
#123456
我的代码:
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
string convert(int n)
{
string s="";
while(n!=0)
{
if(n%13>9)
s+=(n%13-10+65);
else
s+=(n%13+'0');
n/=13;
}
return s;
}
void print(string t)
{
if(t.length()==0)
printf("00");
else
if(t.length()==1)
printf("0%c",t[0]);
else
printf("%c%c",t[1],t[0]);
}
int main()
{
int a,b,c,i,j,k;
string t;
cin>>a>>b>>c;
printf("#");
t=convert(a);
print(t);
t=convert(b);
print(t);
t=convert(c);
print(t);
printf("\n");
return 0;
}
别人的代码:
差距还是有的!
#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
char radix[13] ={
'0', '1', '2', '3', '4', '5', '6', '7', '8', '9', 'A', 'B', 'C'
};
int main() {
int r, g, b;
scanf("%d%d%d", &r, &g, &b);
printf("#");
printf("%c%c", radix[r / 13], radix[r % 13]);
printf("%c%c", radix[g / 13], radix[g % 13]);
printf("%c%c", radix[b / 13], radix[b % 13]);
return 0;
}
加油!少年
还没有评论,来说两句吧...