PAT 甲级 1061 Dating (20 分) 我的代码+别人的代码
1061 Dating (20 分)
Sherlock Holmes received a note with some strange strings: Let's date! 3485djDkxh4hhGE 2984akDfkkkkggEdsb s&hgsfdk d&Hyscvnm
. It took him only a minute to figure out that those strange strings are actually referring to the coded time Thursday 14:04
-- since the first common capital English letter (case sensitive) shared by the first two strings is the 4th capital letter D
, representing the 4th day in a week; the second common character is the 5th capital letter E
, representing the 14th hour (hence the hours from 0 to 23 in a day are represented by the numbers from 0 to 9 and the capital letters from A
to N
, respectively); and the English letter shared by the last two strings is s
at the 4th position, representing the 4th minute. Now given two pairs of strings, you are supposed to help Sherlock decode the dating time.
Input Specification:
Each input file contains one test case. Each case gives 4 non-empty strings of no more than 60 characters without white space in 4 lines.
Output Specification:
For each test case, print the decoded time in one line, in the format DAY HH:MM
, where DAY
is a 3-character abbreviation for the days in a week — that is, MON
for Monday, TUE
for Tuesday, WED
for Wednesday, THU
for Thursday, FRI
for Friday, SAT
for Saturday, and SUN
for Sunday. It is guaranteed that the result is unique for each case.
Sample Input:
3485djDkxh4hhGE
2984akDfkkkkggEdsb
s&hgsfdk
d&Hyscvnm
Sample Output:
THU 14:04
第一次写,没读懂题意,过了三个测试点。
题目大意: 给你两对字符串,按照如下规则从中解码出时间——
- 第一对儿字符串的第一个相同的大写字母,其所在字母表顺序表示星期数,如A是第一个字母,表示第一天,即星期一。我们也可以由此推出,这个所谓的第一个相同的大写字母有两个隐含条件,第一个是位置也要相同,第二个是有效取值范围在A~G之间(毕竟一周只有7天);
2.第一对儿字符串的第二个相同的大写字母,其对应24进制(0 ~ 9,A ~ N)的代表小时数,如字母A,表示10点;同1,这里隐含一个条件,即有效的取值范围; - 第二对儿字符串第一个相同的字母,其所在位置代表分钟数。这里也隐含了一个条件,并不区分大小写。
- 输出格式:按照DAY HH:MM的形式输出,注意补零。
我的代码:
#include<iostream>
#include<cstdio>
#include<ctype.h>
#include<map>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
string w[8]={"","MON","TUE","WED","THU","FRI","SAT","SUN"};
string a,b,c,d;
char t[3];
int i,j,cnt=0,k;
cin>>a>>b>>c>>d;
int len=a.length()>b.length()?b.length():a.length();
for(i=0;i<len;i++)
{
if(a[i]==b[i])
if(cnt<1)
{
if(a[i]>='A'&&a[i]<='G')
t[cnt++]=a[i];
}
else
{
if((a[i]>='A'&&a[i]<='N')||(a[i]>='0'&&a[i]<='9'))
t[cnt++]=a[i];
}
if(cnt>1)
break;
}
cout<<w[t[0]-'A'+1];
printf(" %02d:",t[1]>='A'?t[1]-'A'+10:t[1]-'0');
len=c.length()>d.length()?d.length():c.length();
for(i=0;i<len;i++)
{
if(c[i]==d[i]&&(c[i]>='a'&&c[i]<='a'+25||c[i]>='A'&&c[i]<='A'+25))
{
break;
}
}
printf("%02d\n",i);
return 0;
}
别人的代码:
#include<bits/stdc++.h>
using namespace std;
map<char,string>mp;
void init()
{
mp['A'] = "MON";mp['B'] = "TUE";
mp['C'] = "WED";mp['D'] = "THU";
mp['E'] = "FRI";mp['F'] = "SAT";
mp['G'] = "SUN";
}
int main()
{
string s1,s2,s3,s4;
cin>>s1>>s2>>s3>>s4;
init();
int minn = min(s1.length(),s2.length()),i;
for(i = 0; i < minn ;i++)
{
if(s1[i] == s2[i] && s1[i] >='A' && s1[i] <= 'G')
{
cout<<mp[s1[i]];
break;
}
}
for(++i; i < minn;i++)
{
if(s1[i] == s2[i])
{
if(s1[i] >= 'A' && s1[i] <= 'N')
{
printf(" %02d:",(10+s1[i]-'A'));
break;
}
else if(isdigit(s1[i]))
{
printf(" %02d:",s1[i]-'0');
break;
}
}
}
minn = min(s3.length(),s4.length());
for(int i = 0; i< minn ;i++)
{
if(s3[i] == s4[i] && isalpha(s3[i]))
{
printf("%02d\n",i);
return 0;
}
}
return 0;
}
还没有评论,来说两句吧...