1190: 零起点学算法97——A == B ?
Description
Give you two integer numbers A and B, if A is equal to B, you should print “YES”, or print “NO”.
Input
each test case contains two integer numbers A and B.
Output
for each case, if A is equal to B, you should print “YES”, or print “NO”.
" class="reference-link">Sample Input 
1 2
2 2
3 3
4 3
Sample Output
NO
YES
YES
NO
HINT
注意A、B数位最多100位。
Source
零起点学算法
Code
位数太大用数组
#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int main()
{
char a[199],b[199];
while(~scanf("%s%s",&a,&b))
{
if(strcmp(a,b)==0)
cout<<"YES"<<endl;
else
cout<<"NO"<<endl;
}
}
还没有评论,来说两句吧...