1178: 零起点学算法85——夹角有多大I
Description
这次xhd面临的问题是这样的:在一个平面内有两个点,求两个点分别和原点的连线的夹角的大小。
注:夹角的范围[0,180],两个点不会在圆心出现。
Input
输入数据的第一行是一个数据T,表示有T组数据。
每组数据有四个实数x1,y1,x2,y2分别表示两个点的坐标,这些实数的范围是[-10000,10000]。
Output
对于每组输入数据,输出夹角的大小精确到小数点后两位。
" class="reference-link">Sample Input 
2
1 1 2 2
1 1 1 0
Sample Output
0.00
45.00
Source
零起点学算法
Code
#include <stdio.h>
#include <stdlib.h>
#include<math.h>
int main()
{
int s;
double x1,x2,y1,y2,m,a,b,c,PI=3.1415926;
scanf("%d",&s);
while(s--)
{
scanf("%lf%lf%lf%lf",&x1,&y1,&x2,&y2);
a=sqrt(x1*x1+y1*y1);
b=sqrt(x2*x2+y2*y2);
c=sqrt((x2-x1)*(x2-x1)+(y2-y1)*(y2-y1));
m=(a*a+b*b-c*c)/(2*a*b);
m=acos(m);
m=m*180/PI;
printf("%.2lf\n",m);
}
return 0;
}
还没有评论,来说两句吧...