POJ Tautology
Tautology
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 12751 | Accepted: 4861 |
Description
WFF ‘N PROOF is a logic game played with dice. Each die has six faces representing some subset of the possible symbols K, A, N, C, E, p, q, r, s, t. A Well-formed formula (WFF) is any string of these symbols obeying the following rules:
- p, q, r, s, and t are WFFs
- if w is a WFF, Nw is a WFF
- if w and x are WFFs, Kwx, Awx, Cwx, and Ewx are WFFs.
The meaning of a WFF is defined as follows:
- p, q, r, s, and t are logical variables that may take on the value 0 (false) or 1 (true).
- K, A, N, C, E mean and, or, not, implies, and equals as defined in the truth table below.
Definitions of K, A, N, C, and E |
w x | Kwx | Awx | Nw | Cwx | Ewx |
1 1 | 1 | 1 | 0 | 1 | 1 |
1 0 | 0 | 1 | 0 | 0 | 0 |
0 1 | 0 | 1 | 1 | 1 | 0 |
0 0 | 0 | 0 | 1 | 1 | 1 |
A tautology is a WFF that has value 1 (true) regardless of the values of its variables. For example, ApNp is a tautology because it is true regardless of the value of p. On the other hand, ApNq is not, because it has the value 0 for p=0, q=1.
You must determine whether or not a WFF is a tautology.
Input
Input consists of several test cases. Each test case is a single line containing a WFF with no more than 100 symbols. A line containing 0 follows the last case.
Output
For each test case, output a line containing tautology or not as appropriate.
Sample Input
ApNp
ApNq
0
Sample Output
tautology
not
#include <iostream>
using namespace std;
const int maxn = 105;
char str[maxn];
int flag[10];
int start;
int judge()
{
int p,q;
switch(str[++start])
{
case 'K': p = judge(); q = judge();return (p&&q);
case 'A': p = judge(); q = judge();return (p||q);
case 'N': return (!judge());
case 'C': p = judge(); q = judge();return (!p||q);
case 'E': return (judge() == judge());
default : return (flag[str[start] - 'p']);
}
}
int main()
{
while(cin>>str)
{
if(str[0] == '0')
break;
int ans = 1;
for(int i=0;i<2;i++)
{
flag[0] = i;
for(int j=0;j<2;j++)
{
flag[1] = j;
for(int k=0;k<2;k++)
{
flag[2] = k;
for(int s=0;s<2;s++)
{
flag[3] = s;
}
for(int t=0;t<2;t++)
{
flag[4] = t;
start = -1;
ans = (ans&&judge());
if(!ans)
break;
}
}
}
}
if (!ans)cout<<"not"<<"\n";
else cout<<"tautology"<<"\n";
}
return 0;
}
还没有评论,来说两句吧...