1298 活动选择
活动选择
Time Limit: 1000 ms Memory Limit: 65536 KiB
Problem Description
学校的大学生艺术中心周日将面向全校各个学院的学生社团开放,但活动中心同时只能供一个社团活动使用,并且每一个社团活动开始后都不能中断。现在各个社团都提交了他们使用该中心的活动计划(即活动的开始时刻和截止时刻)。请设计一个算法来找到一个最佳的分配序列,以能够在大学生艺术中心安排不冲突的尽可能多的社团活动。
比如有5个活动,开始与截止时刻分别为:
最佳安排序列为:1,4,5。
Input
第一行输入活动数目n(0<n<100);
以后输入n行,分别输入序号为1到n的活动使用中心的开始时刻a与截止时刻b(a,b为整数且0<=a,b<24,a,b输入以空格分隔)。
Output
输出最佳安排序列所包含的各个活动(按照活动被安排的次序,两个活动之间用逗号分隔)。
Sample Input
6
8 10
9 16
11 16
14 15
10 14
7 11
Sample Output
1,5,4
#include <bits/stdc++.h>
using namespace std;
struct node{
int a,b,num;
}s[110];
bool cmp(struct node x,struct node y){
return x.b<y.b;
}
int main()
{
int n,end;
std::cin >> n;
for(int i = 0; i < n; i++){
std::cin >> s[i].a >> s[i].b;
s[i].num = i+1;
}
sort(s,s+n,cmp); //按照结束先后时间排序
end = s[0].b;
std::cout << s[0].num;
for(int i = 1; i < n; i++){
if(s[i].a>=end){
end = s[i].b;
std::cout << "," <<s[i].num;
}
}
std::cout << '\n';
return 0;
}
还没有评论,来说两句吧...