PAT 1044 火星数字 (20分)(Java)
题目描述:
火星人是以 13 进制计数的:
地球人的 0 被火星人称为 tret。地球人数字 1 到 12 的火星文分别为:jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec。火星人将进位以后的 12 个高位数字分别称为:tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou。例如地球人的数字 29 翻译成火星文就是 hel mar;而火星文 elo nov 对应地球数字 115。为了方便交流,请你编写程序实现地球和火星数字之间的互译。
输入格式:
输入第一行给出一个正整数 N(<100),随后 N 行,每行给出一个 [0, 169) 区间内的数字 —— 或者是地球文,或者是火星文。
输出格式:
对应输入的每一行,在一行中输出翻译后的另一种语言的数字。
输入样例:
4
29
5
elo nov
tam
输出样例:
hel mar
may
115
13
具体实现:
package com.hbut.pat;
import java.io.BufferedInputStream;
import java.util.Scanner;
public class Pat_1044 {
public static void main(String[] args) {
Scanner sc = new Scanner(new BufferedInputStream(System.in));
int N= sc.nextInt();
if(N>=100){
return;
}
String input = "";
String a[] ={ "tret","jan", "feb", "mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec"};
String b [] ={ "tret","tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou"};
int jinwei=0;
int diwei =0;
int temp;
sc.nextLine();
String inputs[]=new String[2];
for(int i=0;i<N;i++){
input=sc.nextLine();
if(input.charAt(0)-'a'>=0 && input.charAt(0)-'a'<=25){
if(input.contains(" ")){
inputs=input.split(" ");
for(int j=0;j<=12;j++){
if(b[j].equals(inputs[0])){
jinwei = j*13;
}if(a[j].equals(inputs[1])){
diwei= j;
}
}
System.out.println(jinwei+diwei);
}else{
for(int j=0;j<b.length;j++){
if(a[j].equals(input)){
System.out.println(j);
break;
}if(b[j].equals(input)){
System.out.println(j*13);
break;
}else if(j==b.length-1){
System.out.println(13);
}
}
}
}else{
temp=Integer.parseInt(input);
if(temp>=169){
return;
}else if(temp>=0&&temp<13){
System.out.println(a[temp]);
}else{
jinwei = temp/13;
diwei = temp % 13;
if(diwei==0){
System.out.println(b[jinwei]);
}else{
System.out.println(b[jinwei]+" "+a[diwei]);
}
}
}
}
}
}
还没有评论,来说两句吧...