STL初步:集合set(安迪的第一个字典(Andy‘s First Dictionary))
set就是数学上的集合——每个元素最多只出现一次。和sort一样,自定义类型也可以构造set,但同样必须定义“小于”运算符。
【问题描述】输入一个文本,找出所有不同的单词(连续的字母序列),按字典序从小到大输出。单词不区分大小写。
【样例输入】
Adventures in Disneyland
Two blondes were going to Disneyland when they came to a fork in the road. The sign read: “Disneyland Left.”
So they went home.
【样例输出】
a
adventures
blondes
came
disneyland
…
注:string已定义了“小于”运算符,直接使用set保存单词集合即可。输入时注意将所有非字母的字符变成空哥,然后利用stringstream得到各个单词。
#include<set>
#include<string>
#include<sstream>
#include<iostream>
using namespace std;
set<string> dict; //string集合
int main()
{
string s,buf;
while(cin>>s)
{
for(int i=0;i<s.length();i++)
{
if(isalpha(s[i]))
{
s[i]=tolower(s[i]);
}
else
{
s[i]=' ';
}
}
stringstream ss(s);
while(ss>>buf)
{
dict.insert(buf);
}
}
for(set<string>::iterator it=dict.begin();it!=dict.end();++it)
{
cout<<*it<<endl;
}
return 0;
}
注:set中元素已从小到大排好
iterator是迭代器,用法类似于指针
还没有评论,来说两句吧...