【水】HDU2026首字母变大写
Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/32768 K (Java/Others)
[显示标签]
Description
输入一个英文句子,将每个单词的第一个字母改成大写字母。
Input
输入数据包含多个测试实例,每个测试实例是一个长度不超过100的英文句子,占一行。
Output
请输出按照要求改写后的英文句子。
Sample Input
i like acm
i want to get an accepted
Sample Output
I Like Acm
I Want To Get An Accepted
Hint
lcy
Source
C语言程序设计练习(四)
Related problem
2023 2032 2024 2022 2028
遍历数组,遇到空格下个字母变大写。即ASCII码减去32;
代码如下:
#include<iostream>
#include<string.h>
using namespace std;
int main(){
char a[100];
while(cin.getline(a,100)){
int n=strlen(a);
a[0]-=32;
for(int i=1;i<n;i++)
if(a[i]==' ')
a[i+1]-=32;
cout<<a<<endl;
}
}
还没有评论,来说两句吧...